vci:script:tutorial

差分

この文書の現在のバージョンと選択したバージョンの差分を表示します。

この比較画面にリンクする

両方とも前のリビジョン 前のリビジョン
次のリビジョン
前のリビジョン
vci:script:tutorial [2020/05/15 10:22]
fumo [コンソールの確認方法]
vci:script:tutorial [2021/11/18 14:13] (現在)
numa
ライン 1: ライン 1:
 ====== VCIスクリプトのチュートリアル ====== ====== VCIスクリプトのチュートリアル ======
-VCIスクリプトはLua言語によって実装されています。\\ +VCIスクリプトはLua言語によって実装されています。 
-ここでは [[vci:​make|VCI作成]] で作成したVCIを使って実際にスクリプトを書き、VCIに追加していきます。\\ + 
-デバックはバーチャルキャストを実行しながら行います。\\+ここでは [[vci:​make|VCI作成]] で作成したVCIを使って実際にスクリプトを書き、VCIに追加していきます。 
 + 
 +デバックはバーチャルキャストを実行しながら行います。
  
 **スクリプトのデバッグを行う場合は、エクスポート時にVCIObject の[Script Enable Debugging]にチェックを有効にしてください。** **スクリプトのデバッグを行う場合は、エクスポート時にVCIObject の[Script Enable Debugging]にチェックを有効にしてください。**
  
----- 
  
 ===== スクリプトの作成 ===== ===== スクリプトの作成 =====
 スクリプトの開発作業を行うフォルダ(ワークスペース)は、 スクリプトの開発作業を行うフォルダ(ワークスペース)は、
   C:/​Users/​__USER_NAME__/​AppData/​LocalLow/​infiniteloop Co,​Ltd/​VirtualCast/​EmbeddedScriptWorkspace   C:/​Users/​__USER_NAME__/​AppData/​LocalLow/​infiniteloop Co,​Ltd/​VirtualCast/​EmbeddedScriptWorkspace
-となります。\\+となります。 
 ここで作成したスクリプトをバーチャルキャスト上で実行することができます。\\ ここで作成したスクリプトをバーチャルキャスト上で実行することができます。\\
  
-{{ :​モデル作成:​vci作成:​vci_sample_folder.png?​200|}}+{{:​モデル作成:​vci作成:​vci_sample_folder.png?​200|}} 
 ※AppDataフォルダが非表示になってる場合は、エクスプローラーオプション(フォルダ設定)から[表示 > 隠しファイル]にチェックを入れてください。 ※AppDataフォルダが非表示になってる場合は、エクスプローラーオプション(フォルダ設定)から[表示 > 隠しファイル]にチェックを入れてください。
  
 === (1)VSCodeでフォルダを開く === === (1)VSCodeでフォルダを開く ===
-ワークスペースをVSCodeで開きます。\\+ワークスペースをVSCodeで開きます。 
 メニューの[ファイル] > [フォルダーを開く]をクリックして、上記ファイルパスを選択してください。 メニューの[ファイル] > [フォルダーを開く]をクリックして、上記ファイルパスを選択してください。
  
ライン 25: ライン 29:
 === (2)対象VCIの専用フォルダ作成 === === (2)対象VCIの専用フォルダ作成 ===
 バーチャルキャスト上でVCIアイテムを出すと、対象のVCIフォルダが自動生成されます。\\ バーチャルキャスト上でVCIアイテムを出すと、対象のVCIフォルダが自動生成されます。\\
-例えばVCISampleというアイテム名であれば、[VCISample]というフォルダが作成されます。\\ +例えばVCISampleというアイテム名であれば、[VCISample]というフォルダが作成されます。 
-\\+
 == THE SEED ONLINEからVCIを入れた場合 == == THE SEED ONLINEからVCIを入れた場合 ==
 VCIを出した時点でフォルダが作成されます。\\ VCIを出した時点でフォルダが作成されます。\\
 この中に書かれた[main.lua]を編集すればスクリプトの書き換えができます。\\ この中に書かれた[main.lua]を編集すればスクリプトの書き換えができます。\\
-保存後に、自動でスクリプトがリロードされるので、SEEDに上げなおす必要はありません。\\+保存後に、自動でスクリプトがリロードされるので、SEEDに上げなおす必要はありません。
  
 === (3)main.luaを作成 === === (3)main.luaを作成 ===
ライン 37: ライン 41:
 [EmbeddedScriptWorkspace/​template.lua]をコピーして[main.lua]にファイル名を変更するのがお勧めです [EmbeddedScriptWorkspace/​template.lua]をコピーして[main.lua]にファイル名を変更するのがお勧めです
  
----- 
  
 ===== コンソールの確認方法 ===== ===== コンソールの確認方法 =====
ライン 43: ライン 46:
 === VCIアイテムのデバッグ設定 === === VCIアイテムのデバッグ設定 ===
  
-VirtualCastの設定画面から[VCI]のタブを選択し、[スタジオにデバッグ情報を表示する]を有効にすると、VR空間内にコンソールが表示されます。+VirtualCastの設定画面から[VCI]のタブを選択し、[スタジオにデバッグ情報を表示する]を有効にすると、バーチャルキャスト内にコンソールが表示されます。
  
 {{:​vci:​script:​vci_settings.png?​400|}} {{:​vci:​script:​vci_settings.png?​400|}}
ライン 51: ライン 54:
 {{:​vci:​script:​system_console.png?​400|}} {{:​vci:​script:​system_console.png?​400|}}
  
-== 全般 ==+== 全コンソール共通の機能 ​==
   * バーチャルキャスト内にデバッグコンソールが生成される   * バーチャルキャスト内にデバッグコンソールが生成される
-  * コンソール画面は自分にだけ表示され、Monobitで同期されていない(ほかの人からは見えない+  * コンソール画面は自分にだけ表示され、ほかの人からは見えない
   * 通常のアイテムと同様に、掴んで動かしたり両手で持って拡縮することは可能   * 通常のアイテムと同様に、掴んで動かしたり両手で持って拡縮することは可能
  
ライン 59: ライン 62:
   * 主にVCIスクリプトのSystemメッセージが表示される  ​   * 主にVCIスクリプトのSystemメッセージが表示される  ​
   * スレッドが停止したり、応答が無い場合など   * スレッドが停止したり、応答が無い場合など
-  * Shared Variable共有変数を使用した場合に、内容がjsonで表示される+  * [[vci/​script/​reference/​exportshared|グローバル同期変数]]を使用した場合に、内容がjsonで表示される(( 1.9.2d以降、SharedVariableConsoleと統合されました。 ))
   * 現在のフレームレート、メモリ使用量が表示される   * 現在のフレームレート、メモリ使用量が表示される
- 
-1.9.2d以降、SharedVariableConsoleと統合されました。  ​ 
  
 == ItemConsole == == ItemConsole ==
ライン 70: ライン 71:
   * アイテム個別のコンソール   * アイテム個別のコンソール
   * アイテムの出現時に生成され、アイテムを消すと一緒に消える   * アイテムの出現時に生成され、アイテムを消すと一緒に消える
-  * 掴んでグリップすることで、以下の表示内容を見ることができる+  * 掴んで使うことで、以下の表示内容を見ることができる
     * Console     * Console
     * SubItem一覧     * SubItem一覧
ライン 77: ライン 78:
     * Audio一覧     * Audio一覧
     * Statistics(統計情報)     * Statistics(統計情報)
- 
-1.9.2d以降、SharedVariableConsoleと統合されました。 
  
 == Statisticsの表示項目 == == Statisticsの表示項目 ==
ライン 97: ライン 96:
  
 ==== その他のデバッグ機能(上級者向け) ==== ==== その他のデバッグ機能(上級者向け) ====
- 
 VCIの設定画面で、[VCIスクリプトのロガーをホストするTCPポート番号]、[VCIスクリプトのデバッガーのTCPポート番号]に0より大きい値のポート番号を指定し、スタジオ内に入室した状態でWebブラウザから[localhost:​ポート番号]にアクセスすることで、VCIアイテムのデバッグ情報を見ることができます。 VCIの設定画面で、[VCIスクリプトのロガーをホストするTCPポート番号]、[VCIスクリプトのデバッガーのTCPポート番号]に0より大きい値のポート番号を指定し、スタジオ内に入室した状態でWebブラウザから[localhost:​ポート番号]にアクセスすることで、VCIアイテムのデバッグ情報を見ることができます。
- 
----- 
  
 ===== サンプルスクリプトをバーチャルキャストで確認する ===== ===== サンプルスクリプトをバーチャルキャストで確認する =====
ライン 117: ライン 113:
 {{:​モデル作成:​vci作成:​vci_sampledebug.png?​direct&​400|}} {{:​モデル作成:​vci作成:​vci_sampledebug.png?​direct&​400|}}
  
-2.バーチャルキャストの中で掴んだ時に、コンソールに、掴んだ回数が表示されたら成功です。\\ +2.バーチャルキャストの中で掴んだ時に、コンソールに、掴んだ回数が表示されたら成功です。
-\\ +
-※チュートリアルなので確認用のスクリプトとなります。\\ +
-※VCIスクリプトの詳細は [[vci:​script:​reference|VCIスクリプトリファレンス]] を参考にしてください。\\+
  
-----+※チュートリアルなので確認用のスクリプトとなります。
  
 +※VCIスクリプトの詳細は [[vci:​script:​reference|VCIスクリプトリファレンス]] を参考にしてください。
 ===== VCIスクリプトを組み込む ===== ===== VCIスクリプトを組み込む =====
  
 {{:​モデル作成:​vci作成:​vci_scriptexport.png?​direct&​400|}} {{:​モデル作成:​vci作成:​vci_scriptexport.png?​direct&​400|}}
  
-1.VCIを作成した時のプロジェクトを開いて、VCI作成のシーンを読み込みます。\\ +1.VCIを作成した時のプロジェクトを開いて、VCI作成のシーンを読み込みます。 
-2.[VCIObject]の[Scripts] > [Size]を1に変更してエンターを押します。\\ + 
-3.Inspectorが拡張するので以下のように入力します。\\ +2.[VCIObject]の[Scripts] > [Size]を1に変更してエンターを押します。 
- [Name] > [main.lua]\\ + 
- [Source] > [(完成したVCIスクリプトを張り付ける)]\\+3.Inspectorが拡張するので以下のように入力します。 
 + 
 + [Name] > [main.lua] 
 + 
 + [Source] > [(完成したVCIスクリプトを張り付ける)] 
 文字数が多い場合(1万5000字以上)エラー表示が出ることがあります。 文字数が多い場合(1万5000字以上)エラー表示が出ることがあります。
-\\ + 
-4.シーンを保存して、再度VCIをExportします。\\ +4.シーンを保存して、再度VCIをExportします。 
- メニューバーから[VRM] > [UniVCI-x.xx] > [Export] を選択し名前をつけて保存します。\\ + 
-5.THE SEED ONLINEにエクスポートしたVCIを上書きすれば、VCIスクリプトが動くVCIの完成になります。\\ + メニューバーから[VRM] > [UniVCI-x.xx] > [Export] を選択し名前をつけて保存します。 
-\\+ 
 +5.THE SEED ONLINEにエクスポートしたVCIを上書きすれば、VCIスクリプトが動くVCIの完成になります。 
vci/script/tutorial.1589505763.txt.gz · 最終更新: 2020/05/15 10:22 by fumo

ページ用ツール